contactor buzzing

Drive motor and electrical issues

contactor buzzing

Postby icedover » Sat Sep 26, 2015 9:53 pm

I was running my E15,and it all of a sudden stopped running. I pushed it into the shop. Figured out that the 20 amp control fuse was blown. Replaced the fuse, and now all I have is the contactors buzzing (chattering) at me when I move the speed control. Any suggestions or remedys?
icedover
 
Posts: 4
Joined: Sat Jun 27, 2015 1:53 am

Re: contactor buzzing

Postby FarmallMan » Mon Sep 28, 2015 4:43 pm

Nothing is immediately coming to mind. A few more questions for you that might help narrow things down: Have you dropped the relay cover that the fuse block mounts on to inspect for damage yet? If not, do so and let us know what you find. Check the connections on the control card well. What do the "Fuel" and Power Use gauges do when you move the control and the relays chatter. Does the PTO still work? How about the lift?

Also, please post what sub model of E15 you have (AA, BA, etc.). This can be found on the serial number plate as the model number suffix.

Nick 8-)
FarmallMan
 
Posts: 123
Joined: Wed Jun 05, 2013 5:23 pm

Re: contactor buzzing

Postby icedover » Tue Sep 29, 2015 1:15 am

Thanks for the Response FarmallMan,
Yes, I inspected for damage, there was none to speak of. But the contactors on the reverse relay were burnt (melted together), so i replaced the Relay. When i use the control the power goes up slightly, but the fuel goes to below the red area on the gauge. The pto, and the lift both work fine.
If i read the serial tag right, my tractor is a CB.
icedover
 
Posts: 4
Joined: Sat Jun 27, 2015 1:53 am

Re: contactor buzzing

Postby FarmallMan » Wed Sep 30, 2015 2:29 pm

I've run into a similar issue on a friend's E15 (the "Fuel" gauge more or less bottoms out and there is a slight current shown) and it's a little bit of an odd one. I'm not thoroughly convinced that I ever really found the true cause. However, I can tell you what I did to his machine. I ended up using a Dremel tool with a wire brush to thoroughly clean up the clips that hold the fuse (make sure they grip tightly) and the .25" quick disconnect terminals of the fuse block. I also replaced the .25" terminals that attach to the fuse block. The only other thing we did was charge the batteries.

On my friend's machine, the motor would try to run with the transaxle out of gear, but wouldn't really do anything in gear.

Nick 8-)
FarmallMan
 
Posts: 123
Joined: Wed Jun 05, 2013 5:23 pm

Re: contactor buzzing

Postby icedover » Tue Nov 03, 2015 12:18 am

Finally got around to working on the Elec-Trak again. I cleaned up the contacts on the fuse boxes. Put a new fuse in and put the machine in the first forward gear and I automatically blew the 20 amp control fuse. Read in the owners manual in troubleshooting and there was nothing on this issue. Suggestions?
icedover
 
Posts: 4
Joined: Sat Jun 27, 2015 1:53 am


Return to Electrical Drivetrain

Who is online

Users browsing this forum: No registered users and 2 guests

cron